Gusto is down

Incident Report for Gusto

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 15:27 PDT

Investigating

We’re investigating now. We’ll keep this page updated as we fix the problem.
Posted Jun 25, 2026 - 15:06 PDT
This incident affected: Gusto.com website, Payroll, Benefits, HR, and Gusto Mobile.