We are aware of some users experiencing site slowness or time outs. Our team is actively working to resolve this issue with an anticipated resolution by 11am PST. We apologize for any inconvenience.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 10:59 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2024 - 10:58 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2024 - 09:40 PDT
Investigating
We are currently investigating this issue.
Posted Apr 15, 2024 - 09:36 PDT
This incident affected: Gusto.com website.