Some Customers may be unable to run payroll at this time

Incident Report for Gusto

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 12:16 PDT

Investigating

Some customers may be unable to run payroll at this time.
Posted Jun 23, 2026 - 11:20 PDT
This incident affected: Payroll, Benefits, HR.