Chat is currently unavailable. If you need to Contact Support, please visit the Help tab within your Gusto account.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 20:11 PDT
Investigating
We are currently investigating this issue.
Posted Apr 06, 2021 - 07:58 PDT
This incident affected: Chat System.